System Requirements

Home • Gallery • Tutorials • Download • Purchase • Site Map
 

System Requirements Overview

The following lists the minimum system requirements necessary to use the Fractal Science Kit:

  • 12 MB free disk space for the product installation
  • Microsoft Windows XP Service Pack 2, Windows Vista, Windows 7, Windows 8, or Windows 10
  • Microsoft .NET Framework 2.0
  • 512 MB RAM (1 GB or more is recommended)

The product installation requires 12 MB of free disk space (additional space may be required if the Microsoft .NET Framework 2.0 needs to be installed on your machine).

The Microsoft .NET Framework 2.0 is required and must be installed prior to running the Fractal Science Kit. See the next section for instructions.

The application has been tested on Microsoft Windows XP Service Pack 2, Windows Vista, Windows 7, Windows 8, and Windows 10. Earlier versions of the Windows operating system may work, but I cannot attest to that at this time.

The application consumes a large amount of memory, primarily used for saving sample data associated with the fractal. You can run the application on a machine with 512 MB RAM but having 1 or 2 GB RAM or more is preferred. Processor speed is also a factor in the user experience. The faster the processor, the better. I would recommend a Pentium 4 class processor or better.

Please install the trial version and verify that the application will run on your machine and that the application's performance and memory requirements are acceptable before you purchase a license for the product.

See Installing the Product for instructions on downloading/installing the Fractal Science Kit on your computer.

Microsoft .NET Framework 2.0

As explained above, the Microsoft .NET Framework 2.0 is required and must be installed prior to running the Fractal Science Kit. For most machines, the Microsoft .NET Framework 2.0 is pre-installed on the machine. For example, it is my understanding that Windows Vista, Windows 7, Windows 8, and Windows 10 machines include the Microsoft .NET Framework 2.0 as pre-installed components. In addition, the Microsoft .NET Framework 2.0 is installed on 99% of all Windows XP machines as well.

If you install the Fractal Science Kit and the the Microsoft .NET Framework 2.0 is not installed, the installation program will install it. You can also install it yourself using the following link provided by Microsoft:

Microsoft .NET Framework 2.0 Redistributables

On this page, under the heading .NET Framework Downloads, click on All .NET Framework Downloads... to open the Download Center. Type .net framework 2.0 in the search box and select the download link that is appropriate for your machine from the resulting list, and follow the instructions found on that page to install the Microsoft .NET Framework 2.0 on your computer.

 

Copyright © 2004-2017 Hilbert, LLC
All rights reserved